Trouble Uploading a Submission

All last night and this morning, I have been trying to upload a document to turnitin through UT Dallas's eLearning site. Every time I attempted to submit my assignment as a Word document, it would say "Uploading...", but literal hours would pass and it would never submit, nor show me any indication that it could not submit. Still just "Uploading...". I tried saving my assignment as a PDF file instead and submitted it again. Same thing happened. I tried doing both on various web browsers (Safari, Chrome, Firefox), though the same problem kept occurring. Eventually I emailed my professor and attached the Word doc, explaining my issue. She was able to submit my assignment for me, no problem. Why is this happening?

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Kinar Ohanian Good news that you were able to submit your work in the end! Have you spoken to your System Administrators for your university's eLearning site to see if the issue was at that end? You could also contact our support team (please email tiisupport@turnitin.com) to see if the issue is on the Turnitin end.

    Reply Like
    • Gill Rowell Yes, my university's eLearning support team suggested I contact Turnitin directly, since it is a 3rd party product they do not support. I'll email Turnitin and see if I can find a solution!

      Reply Like
  • We've seen this due to some issues with the browser, so far we've always resolved it by clearing browser cookies and cache so I would recommend that in all your browsers. I assume it's something that turnitin changed in the past few months, because we never saw this issue before then.

    Reply Like
    • Kathy Williams I will try that! My initial problem is just figuring out whether the issue is coming from eLearning or Turnitin.

      Reply Like
Like Follow
  • 2 mths agoLast active
  • 4Replies
  • 37Views
  • 3 Following